Instalarea WooCommerce 3

In acest articol

Configuratie minima necesara WooCommerce 3.0.x-3.5.3 / WordPress 4.7.x-4.9.x

Pentru a putea rula WooCommerce 3 fara probleme, este recomandat un numar minim de 128 MB de memorie pentru procesul care va rula PHP, altfel vei primi un avertisment, iar viteza magazinului online bazat pe WooCommerce 3 va fi lenta. 

Versiunile de WooCommerce 3  compatibile cu modulul SmartBill sunt versiunile 3.0.x (3.3.0, 3.3.1, 3.3.2, 3.3.3 etc.) pana la 3.5.3 inclusiv. In cazul in care ai o versiune mai veche, in setarile modulului SmartBill vei primi un mesaj de atentionare (dupa instalare).

Versiunea platformei PHP necesara pentru WooCommerce 3 este fie >= PHP 7.0.13 sau >= 7.1.0.

Modulele de PHP necesare sunt : 

  • curl
  • Date/Time
  • DOM
  • POSIX Regex
  • Filter
  • FTP
  • GD
  • Hash
  • iconv
  • JSON
  • libxml
  • mbstring
  • MySQL
  • OpenSSL
  • PCRE
  • SimpleXML
  • Sockets
  • SPL
  • Tokenizer
  • XML Parser
  • XML Reader
  • Zlib

In functie de modul in care ai instalat WooCommerce 3 (din browser sau din linia de comanda), treci printr-un proces care va verifica daca ai aceste module instalate. In cazul in care doresti sa vezi care sunt aceastea, poti crea un fisier info.php in directorul principal al site-ului tau cu urmatorul continut:

<?php 

phpinfo(); 

?>

Apoi poti verifica informatiile in browser accesand: https://numele-siteului-dvs.ro/info.php

Mai multe detalii despre cum puteti optimiza magazinul online WooCommerce 3 puteti gasi pe link-ul oficial (disponibil in limba engleza): https://codex.wordpress.org/WordPress_Server_Optimization

ATENTIE!

Inainte de instalarea modulului, asigura-te ca ai configurat datele din contul SmartBill corect.

Instalare Wordpress / WooCommerce 3 folosind cPanel

Deoarece WooCommerce 3 ruleaza pe platforma PHP, exista posibilitatea de a administra serverul printr-o interfata grafica web numita cPanel - oferita de furnizorul de hosting.

In cazul in care beneficiezi de un astfel de context, poti urma pasii de mai jos pentru a instala WooCommerce 3 (platforma, nu modulul SmartBill) prin intermediului utilitarului Softaculous. 

In primul rand, ai nevoie de un loc pe serverul web unde sa instalati WooCommerce 3. Acesta poate sa fie public_html sau www - care este directorul radacina al serverului dvs. sau poate sa fie un subdomeniu. 

Mai jos este ilustrat exemplul crearii unui subdomeniu ca si container care va fi folosit  pentru a instala WooCommerce 3. In cazul in care folosesti  public_html poti ignora acest pas.

Apasa pe butonul Create si subdomeniul va fi creat. Acest pas este util si daca doresti sa testezi o noua varianta de WooCommerce 3 - avand deja un site activ - pentru a exista practic o zona de testare.

Foloseste bara de cautare pentru a identifica “softaculous”, utilitarul care ajuta la instalarea WooCommerce 3 printr-un “wizard” pas cu pas.

Dupa intrarea in Softaculous, in partea din stanga sus, folosind bara de cautare identifica “Wordpress”. Dupa selectia pachetului software, apasa I nstall Now si asigura-te ca in campul Choose the version you want to install :e selectata varianta Wordpress 4.9.9.

Choose Protocol: daca ai un certificat de securitate/criptare SSL, alegi https://, altfel alegeti http:// (pe viitor va fi nevoie sa aveti un certificat SSL care sa autentifice site-ul si detinatorul acestuia)

Choose Domain: poti alege fie numele-domeniului-dvs.ro, fie numele subdomeniului creat anterior (daca este cazul) 

In Directory: poti lasa acest camp gol sau daca ai un site separat de magazinul online, poti introduce aici magazin, iar rezultatul va fi numele-domeniului-dvs.ro/magazin- locul unde se va instala WooCommerce 3

Admin username / Admin Password / First Name / Last Name / Admin email - sunt campuri importante - practic aici setezi datele de conectare in interfata de administrare.

Ai primit raspuns la intrebarea ta? Multumim pentru feedback Eroare trimitere feedback